User Rating: 0 / 5

Star InactiveStar InactiveStar InactiveStar InactiveStar Inactive

Installed requests 2.8.1, then climbs steadily following error :

/local/lib/python2.7/site-packages/requests/packages/urllib3/util/ssl_.py:100: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see https://urllib3.readthedocs.org/en/latest

o solve this problem, you must set python 2.7.9 or higher. Alternatively, use an older version of the library requests:

sudo pip install requests==2.5.3

User Rating: 0 / 5

Star InactiveStar InactiveStar InactiveStar InactiveStar Inactive

I wanted to install gevent 1.0.2 to MacBook with El Capitan, but the installation is completed the following error:

    libev/ev.c:4675:3: warning: unused variable 'ocur_' [-Wunused-variable]
    
      array_needsize (ev_async *, asyncs, asyncmax, asynccnt, EMPTY2);
    
      ^
    
    libev/ev.c:1758:22: note: expanded from macro 'array_needsize'
    
          int ecb_unused ocur_ = (cur);                                     \
    
                         ^
    
    14 warnings and 1 error generated.
    
    error: command 'cc' failed with exit status 1
    
    ----------------------------------------
    Command "/Users/Documents/workspace/env/bin/python -c "import setuptools, tokenize;__file__='/private/var/folders/3_/2czydczx3pj732hprb91b_x40000gp/T/pip-build-fTtcnZ/gevent/setup.py';exec(compile(getattr(tokenize, 'open', open)(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record /var/folders/3_/2czydczx3pj732hprb91b_x40000gp/T/pip-87matg-record/install-record.txt --single-version-externally-managed --compile --install-headers /Users/Documents/workspace/env/include/site/python2.7" failed with error code 1 in /private/var/folders/3_/2czydczx3pj732hprb91b_x40000gp/T/pip-build-fTtcnZ/gevent

User Rating: 0 / 5

Star InactiveStar InactiveStar InactiveStar InactiveStar Inactive

When you try to run the command virtualenv env through Jenkins, I stumbled upon the following problem:

New python executable in env/bin/python
Installing distribute.............................................................................................................................................................................................done.
Installing pip...
  Error [Errno 2] No such file or directory while executing command /home/jenkins/worksp...env/bin/easy_install /usr/share/python-virtualenv/pip-1.1.tar.gz
...Installing pip...done.
Traceback (most recent call last):
  File "/usr/bin/virtualenv", line 3, in <module>
    virtualenv.main()
  File "/usr/lib/python2.7/dist-packages/virtualenv.py", line 938, in main
    never_download=options.never_download)
  File "/usr/lib/python2.7/dist-packages/virtualenv.py", line 1054, in create_environment
    install_pip(py_executable, search_dirs=search_dirs, never_download=never_download)
  File "/usr/lib/python2.7/dist-packages/virtualenv.py", line 643, in install_pip
    filter_stdout=_filter_setup)
  File "/usr/lib/python2.7/dist-packages/virtualenv.py", line 976, in call_subprocess
    cwd=cwd, env=env)
  File "/usr/lib/python2.7/subprocess.py", line 679, in __init__
    errread, errwrite)
  File "/usr/lib/python2.7/subprocess.py", line 1249, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory

The problem was that I was trying to create a virtual environment being in a folder named "just for testing". To solve this problem, it is sufficient to rename the folder name so that it does not contain any spaces - "just_for_testing".

User Rating: 0 / 5

Star InactiveStar InactiveStar InactiveStar InactiveStar Inactive

When you try to run the command pip install selenium through Jenkins, I stumbled upon the following problem:

Running setup.py install for selenium

... creating build/lib.linux-x86_64-2.7/selenium/webdriver/firefox/x86 copying py/selenium/webdriver/firefox/x86/x_ignore_nofocus.so -> build/lib.linux-x86_64-2.7/selenium/webdriver/firefox/x86 running install_lib creating /usr/local/lib/python2.7/dist-packages/selenium error: could not create '/usr/local/lib/python2.7/dist-packages/selenium': Permission denied

The problem was that I tried to install the module in the virtual environment being in a folder named "just for testing". To solve this problem, it is sufficient to rename the folder name so that it does not contain any spaces - "just_for_testing".

User Rating: 0 / 5

Star InactiveStar InactiveStar InactiveStar InactiveStar Inactive

To correct this problem, follow these steps:

  1. Open the subfolder bin in jmeter. In my case it /apache-jmeter-2.13/bin/
  2. Open the file jmeter with any text editor
  3. Correct the value HEAP="-Xms512m -Xmx512m" to HEAP="-Xms512m -Xmx1024m":

  4. Save the file
  5. Rerun jmeter

We have 15 guests and no members online